Data Delayed - Snowflake - 2025-12-16

Incident Report for BMLL Status Dashboard

Resolved

We are pleased to inform you that all Reference and Trades Plus files are now available in Snowflake for 2025-12-16.

This alert will now be closed.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, don't hesitate to contact the BMLL support team at support@bmlltech.com.

Your sincerely,

BMLL Support Team
Posted Dec 17, 2025 - 13:23 UTC

Update

We wanted to update you on the status of the delays in uploading Reference and Trades Plus files to Snowflake across various venues.

Our team has resolved the issue, and all European and APAC venues are now accessible in Snowflake. We are still monitoring the uploads of AMERICAS venues. We recognise the inconvenience this delay may cause and sincerely apologise for any disruption to your work.

We will provide regular updates on the investigation progress through the BMLL Status Page. For further questions and support, don't hesitate to contact the BMLL support team at support@bmlltech.com.

Yours sincerely,

BMLL Support Team
Posted Dec 17, 2025 - 12:46 UTC

Identified

We have identified an issue that caused delays in uploading Reference and Trades Plus files to Snowflake across various venues.

Our team has resolved the problem and is actively monitoring the uploads while restoring services as swiftly as possible. We understand the inconvenience this delay may cause and sincerely apologise for any disruption to your work.

We will provide regular updates on the investigation progress through the BMLL Status Page. For further questions and support, don't hesitate to contact the BMLL support team at support@bmlltech.com.

Yours sincerely,

BMLL Support Team
Posted Dec 17, 2025 - 10:24 UTC
This incident affected: BMLL Data Feed (Snowflake).