Transfer Delays - Multiple venues - 2026-08-19

Incident Report for BMLL Status Dashboard

Monitoring

Our supplier has identified and deployed a fix to resolve the transfer processing issue, which has been confirmed to be affecting all new file transfers via Revelate.

- All transfers delayed on 2026-08-19 have been completed
- Transfers from 2026-08-20 are completing successfully as the processing backlog clears
- No further delays are anticipated

We remain in close coordination with our supplier to verify system stability and are actively monitoring all transfer activity.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Aug 20, 2026 - 21:26 UTC

Investigating

We are investigating an issue resulting in delayed cloud transfers via Revelate. This is currently affecting Daily Analytics file transfers for US, full impact analysis is ongoing.

Other delivery platforms are unaffected.

Our engineers are working with the vendor to accelerate resolution. We will provide regular updates on the investigation progress through the BMLL Status Page.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Aug 20, 2026 - 15:53 UTC
This incident affects: BMLL Data Feed (Revelate).