Data Delayed - Nasdaq Nordic - 2026-04-23

Incident Report for BMLL Status Dashboard

Update

The issue is still being investigated for the following exchanges and their associated Market Identifier Codes (MICs). No ETA has been provided yet for a resolution:

Nasdaq Nordic: Vilnius [XLIT]

Nasdaq Nordic: Copenhagen [XCSE]

Nasdaq Nordic: First North Sweden - Norway [ONSE]

Nasdaq Nordic: Helsinki [XHEL]

Nasdaq Nordic: Iceland [XICE]

Nasdaq Nordic: Riga [XRIS]

Nasdaq Nordic: Stockholm [XSTO]

Nasdaq Nordic: Tallinn [XTAL]

Our engineers are working to ensure that data is available as soon as possible. We will provide regular updates on the investigation progress through the BMLL Status Page.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Apr 24, 2026 - 16:49 UTC

Update

Regrettably, the processing of data for the following exchanges and their associated Market Identifier Codes (MICs) is further delayed due to a technical issue:

Nasdaq Nordic: Vilnius [XLIT]

Nasdaq Nordic: Copenhagen [XCSE]

Nasdaq Nordic: First North Sweden - Norway [ONSE]

Nasdaq Nordic: Helsinki [XHEL]

Nasdaq Nordic: Iceland [XICE]

Nasdaq Nordic: Riga [XRIS]

Nasdaq Nordic: Stockholm [XSTO]

Nasdaq Nordic: Tallinn [XTAL]

Our engineers are working to ensure that data is available as soon as possible. We will provide regular updates on the investigation progress through the BMLL Status Page.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Apr 24, 2026 - 13:26 UTC

Update

Data for the following exchanges and their associated Market Identifier Codes (MICs) is delayed as a result of delayed file generation by our supplier:

Nasdaq Nordic: Vilnius [XLIT]

Nasdaq Nordic: Copenhagen [XCSE]

Nasdaq Nordic: First North Sweden - Norway [ONSE]

Nasdaq Nordic: Helsinki [XHEL]

Nasdaq Nordic: Iceland [XICE]

Nasdaq Nordic: Riga [XRIS]

Nasdaq Nordic: Stockholm [XSTO]

Nasdaq Nordic: Tallinn [XTAL]

Missing raw data has been collected and processing is now in progress. We expect market data to be fully available by 14:00 UTC and metrics data is expected by 15:00 UTC. We will provide regular updates on the progress through the BMLL Status Page.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Apr 24, 2026 - 12:48 UTC

Identified

Data for the following exchanges and their associated Market Identifier Codes (MICs) is delayed as a result of delayed file generation by our supplier:

Nasdaq Nordic: Vilnius [XLIT]

Nasdaq Nordic: Copenhagen [XCSE]

Nasdaq Nordic: First North Sweden - Norway [ONSE]

Nasdaq Nordic: Helsinki [XHEL]

Nasdaq Nordic: Iceland [XICE]

Nasdaq Nordic: Riga [XRIS]

Nasdaq Nordic: Stockholm [XSTO]

Nasdaq Nordic: Tallinn [XTAL]

Our engineers are working with the supplier to accelerate delivery and processing will begin as soon as the data is available. We will provide regular updates on the progress through the BMLL Status Page.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Apr 24, 2026 - 10:48 UTC

Investigating

We are currently investigating a delay in generating data for the following exchanges and their associated Market Identifier Codes (MICs):

Nasdaq Nordic: Vilnius [XLIT]

Nasdaq Nordic: Copenhagen [XCSE]

Nasdaq Nordic: First North Sweden - Norway [ONSE]

Nasdaq Nordic: Helsinki [XHEL]

Nasdaq Nordic: Iceland [XICE]

Nasdaq Nordic: Riga [XRIS]

Nasdaq Nordic: Stockholm [XSTO]

Nasdaq Nordic: Tallinn [XTAL]

Our engineering team is actively investigating the root cause of the problem to ensure a swift resolution. We will provide regular updates on the investigation progress through the BMLL Status Page.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Apr 24, 2026 - 05:54 UTC
This incident affects: Data - Equities & ETFs - EMEA (Nasdaq Nordic: Vilnius [XLIT], Nasdaq Nordic: Copenhagen [XCSE], Nasdaq Nordic: First North Sweden - Norway [ONSE], Nasdaq Nordic: Helsinki [XHEL], Nasdaq Nordic: Iceland [XICE], Nasdaq Nordic: Riga [XRIS], Nasdaq Nordic: Stockholm [XSTO], Nasdaq Nordic: Tallinn [XTAL]).