Data Delayed - BSE - 2025-09-22

Incident Report for BMLL Status Dashboard

Update

We continue to investigate a delay in generating data for the following exchanges and their associated Market Identifier Codes (MICs):

BSE [XBOM] - 2025-09-22

Our engineers are working with the supplier to accelerate delivery and processing will begin as soon as the data is available. We will provide regular updates on the investigation progress through the BMLL Status Page.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Sep 25, 2025 - 08:44 UTC

Investigating

We are currently investigating a delay in generating data for the following exchanges and their associated Market Identifier Codes (MICs):

BSE [XBOM] - 2025-09-22

Our engineering team is actively investigating the root cause of the problem to ensure a swift resolution. We will provide regular updates on the investigation progress through the BMLL Status Page.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Sep 23, 2025 - 06:06 UTC
This incident affects: Data - Equities & ETFs - APAC (BSE [XBOM]).